+5
Fixed

GCA 3.0.8 bugs

Michal Varga 6 years ago updated by greatapo 5 years ago 22
1 day free premium keys not working - tryed google chrome and firefox, many keys..clearing browser cache blabla..nothing works..previously worked. Tryed both keys from old site apo.users.uth.gr and from new one gladiatuscrazyaddon.tk

In firefox version, instead of expiration of packages there is - Undefined_Locale[OPTIONS_PACKAGES_EXPIRED_PACKAGES]Undefined_Locale[OPTIONS_PACKAGES_EXPIRED_HOURS]

Function to search players without guild dont work too, and there is same bug, undefined__blabla..

Packages Gold Counter: default values where changed to 'All Pages' and 'Calculate item values'  - no change, default is still the same - calculate gold..

gladiatuscrazyaddon.tk highscroe is bugged, when you choose other rank atribute like charisma you get back to main page

Simulator button ingame not working still








Answer

Answer
Planned
Thank you very much for your bug report!
I have a lot of work to do and no time. I wil try to fix these all.
Answer
Planned
Thank you very much for your bug report!
I have a lot of work to do and no time. I wil try to fix these all.
No problem man, glad to help. I understand, just wanted to inform you.
It is very helpful because you have gather almost all the problems i one post. I cant predict all the problems, it is not easy and it needs much time testing and i can't do that always... your (user's feedback) feedback is precious!
- premium keys not working : now working
- some firefox translations : will be fixed in the next version
- search players without guild : search putting "from: 105 to 100" (max lvl first)
- Packages Gold Counter, changed default values : will be fixed in the next version
- gladiatuscrazyaddon.tk highscroe is bugged : now working
- ingame simulator button not working : it is related to the premium system, now working *

* go to setting and click the save button at the premium category to reload your key's data
-One day premium keys still not working for me (tried everything again). After you posted this comment that you made fixes, the one day premium keys "keygen" part site for gca became unavaible (when i move slider to left and click 1 day key, gets redirected to adf.ly, and when i click skip ad it brings me back to donate site, without key, this previously worked normally), and keys from old site apo.users.uth.gr are not working.

-Ye, player searcher works as you said, but i advice to change it in next version so lower level will be first, and if possible make it avaible for guild members too, not only for guild admins, in my guild im in position as recruiter so it would be really helpful.

Thanks for your hard work, you make ma game easier.
- Try again now. I am working on the site and i change things ^_^
- I have already changed the "from" to "Max" and "to" to "Min" in the next version... i think it will be clear now :D
Yes, its generating keys now, but they still dont work for me :/

great :)
+1
Try one more time please :)
I just finished with the server :P, now you can see how many free keys have been generated and how many donations have been made :)
But i just tested it and it works just fine! :/
To see if your key works, go to packages, because the numbers of days that will be displayed is 0 since the 1 day is some miliseconds smaller... :) maybe this is why you don't see the key working :)
i must fix this :)
finally managed to get it work, but only in chrome, so problem must be with firefox version. I found another, not bug, but - top right corner, where is text get gca premium free, when you click it, you get redirected to old gca site, and its not showing the reimaning days when you have key working :)
No this works fine in chrome and it worked in firefox too in previous version - in gca settings - premium key, it showed 1 day left :) But it was in top right corner too, now its missing, and when you click on top right corner - GET GCA PREMIUM FREE! - you get redirected to old gca site. I meant this.

Generated 1 day keys works online in chrome, shows one day left in gca settings - premium key, show number of things in market and type of items in auction. Firefox - keys do not work, 0 day left, no number of items in market, no type of items in auction (gca premium text instead, you know it..)
It was the same in the previous versions, i haven't change these function in the code :)

For firefox, it must be a cashe problem... the code is the same. Maybe if you try tomorrow it will work.

The problems that firefox has now are because i forgot to replace the new translation files when i made the firefox version :P
yes, do not worry, i have already fix the old site link but i should take care the 0 days problem that i told you above :)
I will search the Firefox problem.
Hey here,

I have still a problem to move packets on Google chrome (only when there is less only 1 page of items / gold and it is fixed after moving one item :o) :
http://nsa34.casimages.com/img/2014/01/05/140105010627728857.png

I want to try on FF, but can't activate 1 day premium key (cache cleaned, etc...).
Hey here Greatapo,

any news about this bug ?
I know that bug... i haven't try to fix it because i am thinking of remaking the whole package system... or the move script that Gladiatus uses... it's just a lot of work and i haven't convince myself to do it :P

The whole package this is sth that definitely need to be remake...
simulator still not work
when i click on simulator it opens GCA site
+1
I am aware of that, it does it on purpose... the site simulator works.
As this is marked as general 3.08 bugs I might as well post it here instead of opening a new tread.
The issue is with quoting large text in guild mail. Unless you manually insert page breaks it tends to get out of page, literally, with no horizontal scroll bar to find it, makes the text lost for all intents and purposes.
this is the max zoomout in firefox that still didn't catch it all.
http://prntscr.com/2vyi74
New version 3.0.9 is on the Chrome Store.

Bugs left:
- gladiatuscrazyaddon.tk highscore is bugged
- quoting large text